UI.setLayoutMode(Continuous) doesn't work

Version 8.7.0
I want to have all pages to be visible, one under the other.
I tried it with UI.setLayoutMode(UI.LayoutMode.Continuous) but it doesn’t work.
The pdf container has an appropiate size for all pages.

Pls check attached simple example. What I am doing wrong ?

    <title>feature test</title>
        function init() {
                    path: './lib', // path to the PDF.js Express'lib' folder on your server
                    licenseKey: 'erYOL5fTH6Qt7nvCTnmQ',
                    initialDoc: './test.pdf'
                }, document.getElementById('pdfcont')
            ).then(instance => {
                const {Core, UI} = instance;

<body onload="init()">
<div id="pdfcont" style="width:600px;height:1500px;background-color: aliceblue"></div>
<script src="lib/webviewer.min.js"></script>

Hello thomas.damer,

I was able to get this working on our demo site: PDF.js Viewer Demo | PDF.js Express
Can you elaborate more on “it doesn’t work”? any errors, unexpected behaviour, etc.

Best regards,

Many Thx for the fast response. I tried it with Chrome and Edge and it works. Seems to be an issue with firefox.
Pls check console output.
Firefox Developer Edition 115.0b9 (64-Bit)

console.table() logDebugInfo.js:44:14
(Position)	Wert
UI version	8.7.0
Core version	8.7.0
webviewer.min.js	8.7.0
Build	Ny8yMC8yMDIyfDJhMWM5ZWYwOA==
WebViewer Server	false
Full API	false
'setCustomModal' deprecated since version 8.5. Please use UI.addCustomModal instead addCustomModal.js:98:10
**Warning: TT: undefined function: 3**

Hello thomas.damer,

I tried on the samples page here: PDF.js Viewer Demo | PDF.js Express with Firefox, and the APIs worked as expected.

Could you post a step by step guide, or a minimal sample to reproduce?

Thank you,

Same issue here in version 8.7.4.

 Core.documentViewer.one('documentLoaded', () => {

This still shows a single page, not a continuous one.
If I add a setTimeout that’s long enough (e.g. 5 seconds) then it correctly switches to continuous layoutmode.
Things to note: I’m initializing the webviewer first, then loading a 3+ MB blob via Core.documentViewer.loadDocument(blobResponse.body).
So it probably has something to do with high(er) rendertimes/file sizes.