Opening bookmarks causes viewer to crash

Hi there,

We are currently running version 7.3.2 and have discovered that opening the bookmarks tab crashes the viewer. I have bumped us up to the latest (7.3.4) and the issue is still there. I have also tried on the demo site and it seemed to work normally there, but I noticed that the demo site appears to be running v7.3.0. I then tried running 7.3.0 locally and it worked properly. So I suspect the bug was introduced some time after 7.3.0.

This is the example of the errors showing in the console:

Uncaught TypeError: n.getIndex is not a function
at Object.getPath (webviewer-ui.min.js:50)
at Object.getOutlineId (webviewer-ui.min.js:50)
at webviewer-ui.min.js:50
at (<anonymous>)
at webviewer-ui.min.js:50
at $i (webviewer-ui.min.js:34)
at Ra (webviewer-ui.min.js:34)
at ml (webviewer-ui.min.js:34)
at us (webviewer-ui.min.js:34)
at ls (webviewer-ui.min.js:34)

Here is a demonstration of the issue:

And here is an example document with bookmarks:
c4611_sample_explain.pdf (86.2 KB)

Let me know if you need any more information.
Cheers, Luke.

Thanks Luke,

I will investigate and get back to you soon.


Hi Luke,

This is fixed in 7.3.5 that was just pushed. Sorry about that!


Hi Logan,

I have updated to 7.3.5, however the viewer is still crashing for me when I expand the bookmarks. Here is another PDF to try:

Cheers, Luke.

Hey there,

Please make sure you have swapped out all assets correctly (including the UI) - I am loading 7.3.5 and it is working just fine for me with both PDFs you sent over.


Hey Luke,

Actually I just reproduced this issue - I beleive this is known and should be fixed soon.


Hey Logan.

Thanks for looking into that.


1 Like

Hey Luke,

I found the cause of the bug - the fix is just in code review. I’ll push a new version as soon as its ready.


Thanks Logan - apprecaited it.

Hey! Just fixed 7.3.6 with this fix (sorry for delay, I was on vacation). Also look forward to 8.0 soon!