Compatibility with React 18.1.0 version, it seems not work with that version

Which product are you using?
PDF.js Express Viewer

PDF.js Express Version

Detailed description of issue
Hello team im trying to install the @pdftron/pdfjs-express-viewer": “^8.7.0”, but it doesnt work with the react 18.1.0 version. When i try to run the code “npm i @pdftron/pdfjs-express-viewer” show me errors about Conflicting peer dependency.

Im working with an example with React 16.6.0 and it works. But i need in my project with React 18.1.0
Expected behaviour

Does your issue happen with every document, or just one?
Im trying to force the install with the next command “npm install --legacy-peer-deps @pdftron/pdfjs-express-viewer” but dont work

Link to document
i dont have right now

Code snippet

Hello, I’m Ron, an automated tech support bot :robot:

While you wait for one of our customer support representatives to get back to you, please check out some of these documentation pages:

Guides:APIs:Forums:

Hello cruzromerobrandon241,

I was able to install React 18.1 and get it to work with PDFJS Express. Here is the zip file with the sample updated:
pdfjs-express-react-sample-react-18.zip (4.0 MB)

Best regards,
Tyler Gordon
Web Development Support Engineer
PDFTron