WebViewer doesn't work in localhost

Which product are you using?

I’m using PDF.js Express Plus
PDF.js Express Version
Version 8.7.4

Detailed description of issue
When I run my project on localhost:8082
web viewer doesn’t loaed
it shows AccessDenied Access DeniedGVNT22WT94SZNG58HjxTWdjItrHOdyN/nZzra8+2mls/rZEizY1cBCeyGQn9D4+D8V1eB6UeslpMdYZj7xXfYDV5Vr+3h6I+TTM/1adGAT4kIGRh0lZD760/l24=

but it works perfect on staging
Expected behaviour
When I run my project on localhost:8082
web viewer should load PDF

Does your issue happen with every document, or just one?
with every document

Link to document
Code snippet
import WebViewer from ‘@pdftron/pdfjs-express’

path: ${process.env.VUE_APP_PUBLIC_URL}/pdfjs-express,
licenseKey: process.env.VUE_PDFJS_EXPRESS_TOKEN!,

Thank you for posting the incident to our forum. We will provide you with an update as soon as possible.

Hi there,

It looks like from the code snippet, everything looks correct.

Could you make sure the url to the document is correct? It looks like when there is a symbol in the end of the URL, you will get a similar error message (note the ’ single quote in url):

Best regards,
Kevin Kim

It doesn’t matter which link I’m using
I also used ‘https://pdftron.s3.amazonaws.com/downloads/pl/demo-annotated.pdf
but have got the same error

Hi there,

Thanks for your response,

If I go to the demo and enter the above url, I am able to load the document.
Do you have any network settings or browser extensions that are blocking the access? Does it work in incognito/private mode or another browser?

Best regards,
Kevin Kim

help me, no foun in my local domain, example: mydomain.local

Hi there,

A screenshot of error messages and even a minimal runnable sample project will help troubleshoot this issue.

Best regards,
Kevin Kim